• 1
DocRich99

The Auto Play dialogue box is no longer opening when I connect my Canon camera to donload pictures.'

Question

Title says it all. Usually, I plug in my Canon to a USB, and a box opens asking me if I want to download pictures. That is no longer happening. I checked my Firefox Control Panel, and Auto Play is indeed selected. Any help? Thanks.

Share this post


Link to post
Share on other sites

6 answers to this question

  • 1
  1. Open AutoPlay by clicking the Start button and going to Control Panel > Hardware and Sound > AutoPlay
  2. Check that “Use AutoPlay for all media devices” is checked
  3. Under pictures check that it has the correct setting as in the image below.
  4. click "save"

alt text

Share this post


Link to post
Share on other sites
  • 1

Ok Rich,

Try this:

  1. Go to Start > All Programs > Accessories and right click “Command Prompt”
  2. Click “Run as administrator”.
  3. At the command prompt, type net start shellhwdetection, and then press ENTER.
  4. Restart your computer.

If that doesn't work

Are you able to view the camera as a mass storage device in explorer if you go to my computer.

Does Autoplay work for other devices such as USB hard drives etc

If you hold down shift when connecting the camera does Autoplay start

With the camera connected, go to Start > Control Panel > Hardware and Sound > Device Manager and check if there are any yellow triangles showing in the list

What version of windows are you using

Share this post


Link to post
Share on other sites
  • 0
  1. Open AutoPlay by clicking the Start button and going to Control Panel > Hardware and Sound > AutoPlay
  2. Check that “Use AutoPlay for all media devices” is checked
  3. Under pictures check that it has the correct setting as in the image below.
  4. click "save"

alt text

 

Hey Simon:

Thanks for your input. I tried changing the settings as you suggested, no luck. The settings I had been using were, "Import Pictures and Videos Using Windows", which used to work fine. But now, I plug in the USB cable, and nada happens.

Rich

Share this post


Link to post
Share on other sites
  • 0

Hi Simon:

the "net start shellhwdetection" did not work.

Answer to your questions:

1) I AM able to view the camera (and download pictures by right clicking)as a storage device n my computer2) Autoplay DOES work for flash drives3) Holding down Shift did not open up autoplay4) NO yellow triangles in Device Manager5) Windows 7 Professional, Version 6

Thanks again for your help! Hopefully, we'll figure this out!

Rich

Share this post


Link to post
Share on other sites
  • 0

Hi Rich,

I tried to replicate the problem with an old Canon powershot A610. I connected it to a win 7 pro x64 version 6 machine.

  1. I went to Start > Control Panel > Hardware and Sound > AutoPlay
  2. Scrolled down to the bottom of the list where it says “Devices” and the Cannon camera was in that list.
  3. I set it to “ask me every time” and Autoplay worked.

When you connect your camera is it listed in devices as mine was above and if so is it set to “ask me everytime”.

If it’s not listed in AutoPlay devices then I can only think this is down to a bad driver. The next step is to unistall the driver and see if the camera is then recognised correctly when you reconnect and install a new driver.

To do this, with the camera connected:

  1. Go to Start > Control Panel > Hardware and Sound > Device Manager.
  2. Find your camera in the list, (you might need to click the arrow to open the list)
  3. Right click on the camera and select “Uninstall”
  4. Select “Delete the driver software for this device”
  5. Click “OK”
  6. If you are prompted to restart your computer then do so.

Now when you reconnect your camera, windows will need to install new device drivers for this device. You can let windows find them or use the cd that came with the camera. I would do whatever you did the first time around since they did work to begin with.

Now hopefully windows will recognise your camera and add it to the list of AutoPlay devices.

If not let me know

Simon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 29 Guests (See full list)

    There are no registered users currently online