• 0
Eddiej wa

cannot upgrade to iPhoto 9.2.1 from 9.1.1

Question

(Am re-posting this as the first one does not appear). This is a problem re getting my photo stream to work. I have a MacBook Air with all of the latest software. For iPhoto I have installed 9.1.1 via the iLife 11 disk. When I tried to upgrade from the Apple site (iPhoto knows that an upgrade is available, specifically 9.2.1 which is needed for iCloud to work) a pop-up says: iPhoto 9.1.0 or later is required to install this update. Note the regular software upgrade site under the apple states that my software is up to date as does the App Store. So something obviously wrong. On the MacRumors blog site several also had this problem and some were fixed by moving the iPhoto application out of a separate folder and back to the Application original site. One person had more problems requiring him to seek expert advice from the Mac App Store Support. His was a more complicated problem as he also had a wrong billing information. He had to remove an icon from the System Preferences site, trash iPhoto and then re-install it and it worked. (I can supply this series of e-mails if desired). I have placed the iPhoto icon back into the application folder on the hard drive as I too had moved it and have done a series of restarts but nothing happened. Do I have to do the trash iPhoto, then re-install?Thanks.

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0

Yes. A reinstall would work best for this kind of problem. I have used Mac OSX just a few times, but all I can tell you from my personal experience is that even the Mac is like a Windows PC - it too can get errors and glitch software.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 19 Guests (See full list)

    There are no registered users currently online