Jump to content
groovyPost Forums

Kill Auto Hyperlinking


Guest appalbarry

Recommended Posts

Guest appalbarry

The one MS Office feature that drives me mad is its determination to turn things into hyperlinks or mailto links. I turn off all of the various well hidden auto-correct settings, but it still does it often enough to drive me insane.

 

Does anyone know a way to completely disable this "feature" so that my Word docs have only normal editable text and not blue, underlined, or clickable words?

 

If I edit a web page I use a web page editor - not Word. This is the dumbest feature ever created.

I`m using Word 2007 these days

Link to comment
Share on other sites

Guest michelsmith

Open Microsoft Word document. Click the 'Microsoft Office' button. Click the 'Word Options' button. Clickthe 'Proofing' button. Click the 'AutoCorrect Options' button. Click the 'AutoFormat As You Type' tab. Clear the 'Internet and network paths with hyperlinks' check box. Click 'OK'

Link to comment
Share on other sites

Guest appalbarry

Already did that, but Word STILL makes hyperlinks when pasting text from elsewhere (eg web pages) that contains a hyperlink. I don't want links ever. I use Word for printed documents only. Adding hyperlinks just makes editing a pain in the butt - as well as turning text blue.

Link to comment
Share on other sites

OK I think I found it however I only have Word 2010 installed and this is where I found it.

 

Like MichelSmith said, it's an option:

 

1 - Open Word 2010, Click File Options

2 - Click Proofing Tab

3 - Click AutoCorrect Options

4 - Click AutoFormat as you type TAB

5 - Uncheck Box - Internet and network paths with hyperlinks

 

Once I did this Word no longer adds hyperlinks to URL's like http://www.groovypost.com when I type or paste them into the document.

Link to comment
Share on other sites

Guest appalbarry

1 - Open Word 2007, Click Office Button; Word Options

2 - Click Proofing

3 - Click AutoCorrect Options

4 - Click AutoFormat as you type TAB

5 - Uncheck Box - Internet and network paths with hyperlink (under Replace as you type)

Did that already, and:

4 - Click AutoFormat TAB

5 - Uncheck Box - Internet and network paths with hyperlink (under Replace)

 

If I type a URL or e-mail address it does nothing - correct.

If I paste plain text of a URL or e-mail address it does nothing - correct.

BUT If I copy a block of text which contains a linked word (part of web page for example) and then paste that into a Word doc, Word also pastes in the link.

 

That`s what I wanted to eliminate. When I paste words into Word I want just the characters, not any hyperlinks that may be contained in the source web page or document.

 

Solution!

To remove Hyperlinks from Text being pasted in from a WebPage or other document, Open Word Options again and Under Advanced | Cut, Copy and Paste | Pasting From Other Programs I had selected: Match Destination Formatting. (The way that I always thought Word should function, matching incoming text to the text into which it is being inserted).

 

What I finally did was change Advanced | Cut, Copy and Paste | Pasting From Other Programs to: Keep Text Only.

dropformat.jpg.246792177bcfea7c061b66139a8ea890.jpg

 

I had assumed that this would insert unformatted plain text, so had ignored it.

In fact it paste-inserts the copied text, with the destination formatting, and without hyperlinks!

 

For those keeping track, killing off auto hyperlinks only takes twelve easy, obvious steps!

 

Now if someone can tell me why Windows 7 keeps changing my keyboard from English to French...

Link to comment
Share on other sites

 

What I finally did was change Advanced | Cut, Copy and Paste | Pasting From Other Programs to: Keep Text Only.

 

 

Very nice find! I went ahead and added a screenshot to your post as well to give people a visual on your fix!

 

BTW - Welcome to groovyPost!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...