Austin

Samsung Galaxy Epic 4g Unresponsive Touch Screen If On USB

Recommended Posts

First off, Samsung has HORRIBLE customer support.

 

Just a few minutes ago I called into Sprint advanced technical support regarding the issue I'm having with the Galaxy S (Epic 4g) touch screen lock-up when connecting to a USB that is attached to a computer.

 

It turns out it isn't a known issue and advanced technical support at Sprint couldn't help me out, so me and the Sprint tech guy called Samsung on a conference call. Here's a few things that went wrong:

  • Hard to understand the Samsung support tech, he had a heavy eastern(indian?) accent. I know outsourcing is common these days so I won't knock them much for this, but it just made things difficult from the very start. And he said his name was Jeff, I know his real name wasn't Jeff. :P
  • Samsung had no record of this issue. I've tested it out on a couple of Epic 4g's now in Radio Shack and at the Sprint store, same thing happens. It's obviously an issue.
  • Samsung requested I send it in to them for "repairs" leaving me phone-less until they finished.
  • I also asked Samsung about the 4G antenna sleep issue to see if it would be resolved in the future, they didn't even know the phone had a 4G antenna!
  • Samsung tech support didn't solve any of my other questions/problems either. They are utterly useless.

 

Sprint on the other hand stayed with me the whole way through, about a 1 hour call total. To Sprint's favor, the tech guy on the phone was friendly and tried to be as helpful as he possibly could. Unfortunately, Sprint didn't know how to fix it but they did offer to replace the phone at one of their stores. Although since it happens on all of the Epic 4G's that won't solve much.

 

In summary:

Sprint "Advanced" "Tech" support doesn't know much.

Samsung tech support doesn't know ANYTHING.

Share this post


Link to post
Share on other sites

Sometimes it better to get on the users forums. Here in The Netherlands we have a community called http:tweakers.net. Its Dutch, but freaking huge. You can find anything about everything there. Like they have a topic for about every phone that comes out here. For the Galaxy S for example the have a topic with over 60 pages, divided over 5 parts. You can ask there anything and get answers you wont get from Samsung it self.

 

You could try it over there, but Im sure there are american communitys about the Epic.

Share this post


Link to post
Share on other sites

You aren't the only one having this problem, it isn't just your particular phone.

 

Here's a list of other people with the same problem, Samsung Galaxy S touch screen is unresponsive when charging or plugged into USB.

 

At least 4 other people who have reported this bug and the phone hasn't even been out a month yet. Plus not many people have it yet because the EPIC 4g is back-ordered several weeks.

 

The phone is great device, my friend have one and this is only problem he has too.

Share this post


Link to post
Share on other sites

Does your friend have LauncherPro Plus installed? With the widgets? Because im seeing this too, and the people that are having the problems have LauncherPro Plus installed with one or more widgets on one of the homescreens.

It also could be the "app drawer" from LauncherPro. Try to download "Home Switcher" and switch to the standard launcher. Then see what happens.

Share this post


Link to post
Share on other sites
Does your friend have LauncherPro Plus installed? With the widgets? Because im seeing this too, and the people that are having the problems have LauncherPro Plus installed with one or more widgets on one of the homescreens.

It also could be the "app drawer" from LauncherPro. Try to download "Home Switcher" and switch to the standard launcher. Then see what happens.

That is a good point! I took your advice and did some testing.

 

I went into Settings > Applications > Manage Applications > LauncherPro - Clear Defaults. That disabled LauncherPro. I went into Task Manager and killed the process just to be sure.

 

Here are my findings: Note that this only applies to performance while plugged into a USB.

  1. By default the Galaxy comes with Samsung's TouchWiz interface, so I tried that one first. With TouchWiz the screen will just lag, it doesn't become fully unresponsive like it did while running LauncherPro.
    Since running TouchWiz seems to make the phone more stable it made me think it was something to do with the interface. TouchWiz was about 95% stable, only some unresponsiveness but it still has lag.
     
  2. Next I tried running it with the bare bones stock Android UI. It then ran near flawlessly, just a little bit of lag with drag-touches.

Of course once you unplug the USB everything goes back to normal and works perfectly regardless which UI are running.

 

Conclusion

The touch screen unresponsiveness is being caused by software errors related to the interface. For some reason when a USB is plugged in the interface can't handle it. This is especially true the more complicated the interface is. LauncherPro will completely lock-up, TouchWiz 2.5 will become partially unresponsive, and the basic Android stock interface is hardly affected.

 

Thanks Beyond Life, now I just need to figure out why plugging it into a USB port is causing all of these problems. But when it is Plugged in I can now avoid the freezing by just running the stock Android UI.

 

On a side-note it is especially strange that when plugged into just the power-outlet charger that it doesn't slow down, it only happens when connected to a computer.

 

Update: The pattern locker appears to also contribute to screen unresponsiveness regardless which interface is running. Just had it lock up on me in the stock UI because of the Lock pattern. Again once I unplugged the USB cord it was completely fine. The USB connection must put a huge strain on the phone or something... This is definitely a problem Samsung needs to fix.

Share this post


Link to post
Share on other sites

Is your epic running 2.1? Because 2.1 cant work with the complete ammount of ram inside. With 2.2 that wil be fixed and your Galaxy will be able to run on the full 512 mb ram and it should go more fluid. If thats the correct word.

Share this post


Link to post
Share on other sites

Glad you were able to figure this out, I have my Samsung Galaxy on pre-order from wirefly. Still got a week before it is here. At least that is what they tell me.

 

I was about to cancel it when I first heard about this problem but I decided not to after reading all of the reviews about how freaking awesome this phone is!

 

Thanks Dex!

Share this post


Link to post
Share on other sites

Thank you! Thank you!

 

I was a few minutes away from throwing my phone against the wall!... After reading this and realizing that my phone was plugged into the wall, via the USB cord, for charging... I quickly unplugged it and everything starting working correctly!! Whoo hoo!

 

I also looked at my applications, and I too had LauncherX installed... which is now quickly... uninstalled!

 

I will pass this information to my friend who works at Sprint... hopefully they can look into it or atleast have a better reply to customers who call for help.

 

Thank you all!

David

Share this post


Link to post
Share on other sites
Thank you! Thank you!

I was a few minutes away from throwing my phone against the wall!... After reading this and realizing that my phone was plugged into the wall, via the USB cord, for charging... I quickly unplugged it and everything starting working correctly!! Whoo hoo!...

...Thank you all!

David

 

Glad it helped out David! I'm still awaiting Android 2.2 (Froyo) on my Galaxy / Epic, but people who have installed the unofficial 2.2 already claim that it fixes this issue.

Share this post


Link to post
Share on other sites

Glad you were able to figure this out, I have my Samsung Galaxy on pre-order from wirefly. Still got a week before it is here. At least that is what they tell me.

 

 

 

 

 

 

Edit by Beyond_Life. Reason: Spam links.

Share this post


Link to post
Share on other sites

Does anyone else's touch screen become unresponsive when the Epic is being charged? My touch screen gets glitchy and only responds to a fraction of touches.I just received mine yesterday and I've already spent more than 6 hours trying to troubleshoot this issue. Most of the google searches that I've found have to do with cheap 3rd party chargers, but I'm using the OEM Samsung charger.I thought it might be the charger, so I went out and purchased 4 different chargers today, but none of them fix the issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Who's Online   0 Members, 0 Anonymous, 12 Guests (See full list)

    There are no registered users currently online