Jump to content
groovyPost Forums

Server 2008 SuperFetch


Recommended Posts

By default on Windows Server 2008, the service is disabled and if you want to enable it you must first create 2 Registry keys then enable the service.

 

First, create the 2 keys

 

Open Regedit:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters

 

Click New --> DWORD (32bit) Value

Type: EnablePrefetcher

Click OK

 

Do it again for superfetch key below

 

Click New --> DWORD (32bit) Value

Type: EnableSuperfetch

Click OK

 

Now configure the Keys

Double click on EnablePrefetcher and type 3 in Value data field and Click Ok. Repeat for the EnableSuperfetch key.

 

Enable the SuperFetch Service

 

Click Start Button and Type Services.msc then press enter. This will bring up the Services on the system.

 

Scroll down until you find the SuperFetch Service. Right click it and click Properties

 

Change the Startup Type of the Service from Disabled to Automatic. Click Apply then Start to start the service.

 

Should be all done. Because you enabled the service to run Automatic, it should be started each time you reboot.

Link to post
Share on other sites
  • 2 weeks later...
  • 1 year later...

By default, the Superfetch service is installed on a Server 2008 system but left disabled. If you try to enable it, the service won't start. This is easily fixed with 2 registry entries lifted from a Vista installation.

 

The registry entries in question are:

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters]

"EnableSuperfetch"=dword:00000003

"EnablePrefetcher"=dword:00000001

 

If you want a cookie-cutter premade .REG file, you can download it here.

 

For those following my '2008 as a Desktop' saga, I'm happy to report I have Diskeeper running under Server 2008 now too. The only thing I am missing from Vista these days is Dreamscene.

Link to post
Share on other sites
  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Who's Online   0 Members, 0 Anonymous, 20 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...