Jump to content
groovyPost Forums

iWeb: Navbar and photo gallery will not load


Go to solution Solved by Jack,

Recommended Posts

This is very frustrating. My site worked before, but now it does not. It looks good in iWeb, but when I publish it, all I see is the Home page. None of the links to the other pages are there. And when I type in the URL for the photo gallery manually, it doesn't load either. It doesn't even work when I publish locally. At my wit's end here!

Link to comment
Share on other sites

  • Solution

First off, iWeb sucks. The way it generates webpages is completely awful and that's why you're having trouble. Instead of creating straight-up HTML, it uses a twisted labyrinth of javascript widgets and XML files. So, essentially, the entire page is built dynamically using client-side scripts. If you ever wanted your page to show up nicely in search engines, fuggedaboutit. You're better off making your page entirely in flash.

So, the navbar and the photo's page both work by pulling data from an XML file. If your page can't get this XML file, then it just fails. I think that's what's happening here.

The fact that it also doesn't work on your local folder indicates to me that your file permissions are wonked up. So, try this for me first:

Go to Applications > Utilities > Disk Utility.

Select your hard drive and click Repair Disk Permissions.

See if that helps.

If it does, then that's good. Try re-uploading.

If it doesn't, try changing the file permissions on your web server. You can do this through an FTP program or your web host's file manager. They are probably all set to 0644 right now. Set it to 0755. Do this for feed.xml and rss.xml (in your photos folder, I believe).

If that STILL doesn't work, go to the root of your website (www or public_html) and look for a file called .htaccess

Open it up in a text editor.

Add these lines:

<Files feed.xml>        Order allow,deny    Allow from all    Satisfy All</Files><Files rss.xml>        Order allow,deny    Allow from all    Satisfy All</Files>

Try again.

if that doesn't work, send me the url to your site and a $5 papa john's coupon and I'll fix it for you.

Link to comment
Share on other sites

First off, iWeb sucks. The way it generates webpages is completely awful and that's why you're having trouble. Instead of creating straight-up HTML, it uses a twisted labyrinth of javascript widgets and XML files. So, essentially, the entire page is built dynamically using client-side scripts. If you ever wanted your page to show up nicely in search engines, fuggedaboutit. You're better off making your page entirely in flash.

So, the navbar and the photo's page both work by pulling data from an XML file. If your page can't get this XML file, then it just fails. I think that's what's happening here.

The fact that it also doesn't work on your local folder indicates to me that your file permissions are wonked up. So, try this for me first:

Go to Applications > Utilities > Disk Utility.

Select your hard drive and click Repair Disk Permissions.

See if that helps.

If it does, then that's good. Try re-uploading.

If it doesn't, try changing the file permissions on your web server. You can do this through an FTP program or your web host's file manager. They are probably all set to 0644 right now. Set it to 0755. Do this for feed.xml and rss.xml (in your photos folder, I believe).

If that STILL doesn't work, go to the root of your website (www or public_html) and look for a file called .htaccess

Open it up in a text editor.

Add these lines:

<Files feed.xml>        Order allow,deny    Allow from all    Satisfy All</Files><Files rss.xml>        Order allow,deny    Allow from all    Satisfy All</Files>

Try again.

if that doesn't work, send me the url to your site and a $5 papa john's coupon and I'll fix it for you.

 

Nice answer!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • Guest pumpkinskin
      By Guest pumpkinskin
      So I'm a Windows person and I just got a MAC and for the life of me I cant figure out how-to edit my local hosts file so I can hit my local test web server. Who can help me?
      I'm running MAC OS X 10.6.7
      Thanks!
    • By alexmvp
      I'm an old-school windows guy but I'm playing with a MAC at work (and typing on it now). Is there a simple way to take a screenshot kinda like the "PrintScreen" button on Windows? Trying to avoid buying Snagit on this MAC.
      Thanks
    • By rogerthat
      My wife just bought a new macbook and got Lion OS X, but I still have Tiger. Is there a way for me to use her install disc to get the latest OS X on my older macbook? When I try, I get an error message: "Mac OS X cannot be installed on this computer."
    • By Austin
      Asim recently wrote me this email:

      ...Our company has a VPN that we loginto, I have a macbook pro machine andi have installed Windows 7 as a guestusing vm virtual box in this syste. Iam wondering, can we creat a vpnconnection on guest OS Windsows 7?
      I'm overwhelmed by the network optionsavailable and was hoping you couldprovide some direction...
    • By MacGirl55
      I tried to download CCleaner on my Mac… it downloaded, but disappeared from my downloads tab, so I wasn’t able to run the install wizard.. I looked for it in Finder, found it, clicked on and it opened… but I didn’t have to set it up.It was the free download version for Mac. I don’t have the page with setting, cookies, advanced options etc why is this? I only have Cleaner and tools options on my side bar, not registry tools options etc and it says Analyze and Clean on the bottom, not run clean etc. Have a I downloaded a partial version? Thanks so much, I know nothing about this, help would be appreciated
  • Who's Online   0 Members, 0 Anonymous, 6 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...