Steve

Question about Windows Defender Service

Recommended Posts

Question from Reader :: Ask MrGroove Email Forum

 

I am familiar with how to disable and uninstall Windows Defender. However, upon reboot, the service for Defender goes from automatic to manual. I can manually restart the service. Then, upon reboot, the service changes back to manual. When the service is changed from manual to automatic, Defender runs as it should. The OS is Vista. The system is an HP Desktop.

 

I have a Gateway laptop also running Vista. I have not have any difficulty with the Gateway. I have the most recent version of Defender on both. I have the most recent Windows update on both.

 

The only items added on the HP were Office and two printers; an HP 1006P and and HP7250.

 

I have a wireless connection using a wireless "g" router. The HP comes with a wireless card. The 7250 is wireless as well. The HP1006 is a usb connection. The laptop and printers are connected by the wireless network.

 

The HP system is about 1 week old. I am in the process of creating recovery disk. I could return the HP to its original state; but feel that this would be too much trouble for Defender. I do use McAfee.

 

I am curious about what is changing the service and how might it affect anything else. Any suggestions?

Thanks,

Allan

 

Hi Allan! Welcome to the groovy Community! :wink:

 

Just read your email and I'm not quite sure what it is you wanted to do. Did you want to disable Windows Defender so it won't run or are you trying to configure it to operate?

 

If you want to disable Windows Defender, take a look at this post in the forum:

 

windows-vista/windows-defender-application-failed-to-initialize-t95517.html

 

Let me know if there are any further questions.

 

If your question is NOT how-to disable Windows Defender, reply here and we can work through it!

 

PS - Don't worry about dropping the system back to factory defaults. We should be able to your question/problem solved no sweat!

 

Thanks

Share this post


Link to post
Share on other sites

Thank you for your rapid response. Do you have any idea of what could be causing the Defender service to change from automatic to manual on reboot? It does so on my Visa HP desktop but not on my Vista HP Laptop. I have not encountered this problem before?

 

Allan

Share this post


Link to post
Share on other sites

Never heard of that. Then again, I've never actually checked my services...

 

So even if the service is set to manual, is it running and working? Are you trying to keep Defender running or turn it off?

 

Personally, I used this method explained here to Turn Windows Defender On or Off:

 

http://www.groovypost.com/howto/microso ... oft-vista/

 

Just check the box.

 

To test out your problem, I just verified that even when I checked the box and turned off Defender, the service remained in AUTOMATIC mode however the service stopped running. When I enabled Windows Defender by rechecking the box the service started.

 

Try to follow that post above to turn it on and off. Let me know if that works for ya!

 

BTW - I'm running Windows Vista 32bit Ultimate Edition

 

-TREX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Who's Online   0 Members, 0 Anonymous, 20 Guests (See full list)

    There are no registered users currently online